Risolto Intervallo che si modifica nella formula

maria60

Utente abituale
5 Novembre 2019
114
18
excel 2016
0
Salve ragazzi,
nel file allegato nel foglio "Rad. Solare" ho delle formule nelle colonna H e I da riga 6 a riga 29,
esempio cella H6:

=SE.ERRORE(SE($G6>$J$4;"";SE.ERRORE(CERCA.VERT($G6;Foglio2!$D$2:$U$500;CONFRONTA(H$5;Foglio2!$D$1:$U$1;0));CERCA.VERT($G6;temporaneo!$D$2:$U$500;CONFRONTA(H$5;temporaneo!$D$1:$U$1;0))));"Dati non disponibili")

$U$500 quando avviene l'aggiornamento del foglio temporaneo tramite la macro Sub Aggiornamento_totale() si modifica il $U$500, cioè 500 mi diventa 280, 337 ecc ecc, sono costretto a modificarlo manualmente nelle colonne specificate sopra.
Idem mi succede anche anche nelle celle C2,C3,C4 dove ho dei subtotali l'intervallo C6:C150 mi si modifica C150
Idem nelle celle D2 e D4 ... mi si modifica D150.
Perché avviene?

Grazie
 

Allegati

maria60

Utente abituale
5 Novembre 2019
114
18
excel 2016
0
Grazie klingklang ... dovevo modificarla così?

=SE.ERRORE(SE($G6>$J$4;"";SE.ERRORE(CERCA.VERT($G6;Foglio2!$D$2:$U$500;CONFRONTA(H$5;Foglio2!$D$1:$U$1;0));CERCA.VERT($G6;INDIRETTO("temporaneo!$D$2:$U$500");CONFRONTA(H$5;temporaneo!$D$1:$U$1;0))));"Dati non disponibili")

......non si modifica piu' il valore 500 resta costante nel rieseguire la macro .... per imparare cosa fa' in particolare "INDIRETTO".

E per:
Idem mi succede anche anche nelle celle C2,C3,C4 dove ho dei subtotali l'intervallo C6:C150 mi si modifica C150
Idem nelle celle D2 e D4 ... mi si modifica D150

esempio in C2

=SUBTOTALE(105;C6:C150)

in essa mi si modifica il 150
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!