Risolto media di numeri che devono essere divisi per classi

francesco.12.13

Nuovo utente
27 Settembre 2021
4
1
excel 2018
0
Buongiorno a tutti, ho cercato tra le varie discussioni ma non ho trovato nulla, quindi scrivo qui. Ho due colonne di numeri, che si ripetono tra loro, li ho dovuti dividere in 3 classi, esempio (0-1)(2-3)(3-4), ovviamente i valori sono altri, potrei allegare anche l'esercizio. Dopo averli divisi in classi devo trovare la media di ogni classe, qui sorge il problema non so come fare. Se qualcuno potrebbe darmi una mano ne sarei grato. grazie mille in anticipo.
 

Allegati

[email protected]

Utente assiduo
Expert
19 Gennaio 2016
4.670
145
Roma
Excel 2016
462
Ciao
A patto di avere bene interpretato per le altezze in L22 da trascinare in basso

=SE.ERRORE(MATR.SOMMA.PRODOTTO((($A$2:$A$335>=I22)*($A$2:$A$335<=J22))*$A$2:$A$335)/MATR.SOMMA.PRODOTTO(($A$2:$A$335>=I22)*($A$2:$A$335<=J22));0)

Adatta i riferimenti per i diametri
 
  • Like
Reactions: francesco.12.13

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!