Risolto Ordinamento Alfabetico - NO Matrici - NO Macro

DanielPope

Utente junior
27 Aprile 2017
55
8
Roma
2007/2013/2016
0
Ciao a tutti,
sto impazzendo per ordinare una colonna in maniera dinamica ma senza applicare VBA o matrici.

Esiste qualche concatenazione assurda di formule per ordinare una colonna?

L'unico modo che è trovato e che funziona è utilizzare le matrici ma mi appensantiscono troppo il foglio di lavoro (in allegato avete un estratto).

La domanda è:
la colonna D (di input) può essere ordinata anche spostando il risultato in colonna E?

Grazie ai volenterosi o ai più esperti di me che mi aiuteranno.

Grazie tante
Daniele
 

Allegati

lukereds

Excel/VBA Expert
Staff
17 Luglio 2018
5.347
145
Milano
www.formazione-milano.net
2013, 2016, Ol
432
ciao,
per ordinare i dati in D in ordine crescente, scrivi in E1 e trascina in basso. Formula da confermare con ctrl shift enter

=INDICE($D$3:$D$58;CONFRONTA(PICCOLO(CONTA.SE($D$3:$D$58;"<="&$D$3:$D$58);RIF.RIGA(A1));CONTA.SE($D$3:$D$58;"<="&$D$3:$D$58);0))
 

[email protected]

Utente assiduo
Expert
19 Gennaio 2016
4.700
145
Roma
Excel 2016
468
Ciao a tutti
Se si vuole evitare lo stato matriciale in E3 da trascinare in basso

=SE.ERRORE(INDICE($D$3:$D$200;CONFRONTA(0;INDICE(CONTA.SE($D$3:$D$200;"<"&$D$3:$D$200)-MATR.SOMMA.PRODOTTO(CONTA.SE(E$2:E2;$D$3:$D$200)););0));"")
 
  • Like
Reactions: DanielPope

Abe76

Utente abituale
23 Agosto 2017
875
45
45
Milano
Office16/19xWin
45
Per assurdo, D @DanielPope
senza usare formule, potrebbe bastarti adiacente all'elenco, una colonna ricavata utilizzando una pivot table.
Impostata con ordinamento alfabetico, e che ogni volta che aggiungi un campo all'elenco originale,
si autopopola semplicemente cliccando sul tasto reflesh di excel, senza utilizzare macro.
Ti allego il risultato che puoi confrontare tu stesso.
 

Allegati

  • Like
Reactions: DanielPope

DanielPope

Utente junior
27 Aprile 2017
55
8
Roma
2007/2013/2016
0
Per assurdo, D @DanielPope
senza usare formule, potrebbe bastarti adiacente all'elenco, una colonna ricavata utilizzando una pivot table.
Impostata con ordinamento alfabetico, e che ogni volta che aggiungi un campo all'elenco originale,
si autopopola semplicemente cliccando sul tasto reflesh di excel, senza utilizzare macro.
Ti allego il risultato che puoi confrontare tu stesso.
anche questa è interessante come soluzione....
 
  • Like
Reactions: Abe76

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!