Risolto ottimizzare condizioni uguaglianza su lista

fg23

Utente junior
9 Luglio 2020
95
8
2016
0
Ciao a tutti,
vorrei ottimizzare nella formula la condizione di uguaglianza tra il nome oggetto della formula (es. A8) e la lista dei nomi (sheet lista).
Quindi anichè inserire in o(…) le n condizioni (potenzialmente infinite), scrivere un qualcosa del tipo se(A8 compreso in lista; then; else).

Nella griglia arancio l'esempio non ottimizzato.
Nella griglia verde lo stesso da ottimizzare.

Grazie mille
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
9.004
345
Latina
Excel 2010
961
Ciao
se ho capito
in B8:
=SE.ERRORE(SE(CERCA.VERT(A8;lista!$B$2:$B$10;1;0)=A8;"Ok");"Ko")

Ti ricordo di dare riscontro o mettere il Risolto a questa discussione:
 
  • Like
Reactions: fg23

fg23

Utente junior
9 Luglio 2020
95
8
2016
0
Ho modificato la struttura del file, che riallego.
La formula funziona. grazie!
Mi chiedevo solo se esiste l'equivalente dell' IN in access (es. se F2 in "lista")… forse sarebbe più leggere come effort dei calcoli.
Grazie
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
9.004
345
Latina
Excel 2010
961
Più o meno è la stessa cosa
in pratica gli dici di verificare se F2 è uguale all'elenco da A2:A8
se trovato mette... eltrimenti...
più semplice di così

ti ho variato la formula così la trascini in basso anche dove vi sono celle vuote.


=SE.ERRORE(SE(F2="";"";SE(F2=CERCA.VERT($F2;$A$2:$A$8;1;0);"label_1"));"label_2")

Ricordatidi sistemare l'altra discussione segnalata sopra,
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!