Risolto problema con formula SOMMA.PIÙ.SE

Stefano

Utente abituale
31 Maggio 2015
182
0
0
Turbigo (MI)
Excel 2013
Miglior risposte
0
#1
bUONGIORNO,
ho un problema con questa formula
=SOMMA.PIÙ.SE(PREZZO_ORI;DATA_RESO;">="&$B$2;DATA_RESO;"<="&$B$3;COD_CAT;$A35)
la colonna DATA_RESO la legge come testo, senza dover intervenire sul database come si puo' risolvere? b2 e b3 sono formato data
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#2
Ciao Stefano se sicuro che B2 e B3 sono dei numeri seriali?
perchè non metti un piccolo allegato cosi ci si lavora direttamente, quando rispondi clicca su modalità avanzata e inserisci un allegato!
ciao aspetto
 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#4
Ciao Stefano,

faccio un tentativo


Codice:
=MATR.SOMMA.PRODOTTO(PREZZO_ORI;(DATA_RESO+0>=$G$1)*(DATA_RESO+0<=$G$2)*(COD_CAT=$F$10))
 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#5
Ciao Stefano,

formula equivalente

=SOMMA(INDICE(PREZZO_ORI*(DATA_RESO+0>=$G$1)*(DATA_RESO+0<=$G$2)*(COD_CAT=$F$10) ; ))

Leva gli spazi dalla formula: mi comparivano le faccine con ; )

Spero sia d'aiuto
 
Ultima modifica:

Stefano

Utente abituale
31 Maggio 2015
182
0
0
Turbigo (MI)
Excel 2013
Miglior risposte
0
#7
ecco, proprio quello che ci voleva, grazie mille
una curiosità come mai importa la data in formato testo? ho 5 colonne importate come data e solo questa non la prende come data, il file è un "dbf"
 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#9
Ciao,

non saprei risponderti: dipende come vengono scaricati i dati. Mi succede spesso con As400, il +0 rimette le cose a posto.
 

Stefano

Utente abituale
31 Maggio 2015
182
0
0
Turbigo (MI)
Excel 2013
Miglior risposte
0
#10
Ho provato anche la tua Gerardo e non mi crederai ma funziona anche la tua :eek: scherzo naturalmente, non avevo dubbi, ci ho perso una sera, avevo capito il problema ma non riuscivo a risolverlo, grazie, sulle tabelle pivot però sono piu' preparato
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#11
Ciao Stefano probabilmente, è una cosa normalissima ogni qualvolta che si scarica qualcosa da internet o da un database è in formato .csv o .txt percui dovrai essere a sistemare il data se, conque avresti potuto creare una colonna aggiuntiva e trasformare la cella in formato testo in numero seriale es. A1+0 ( il +0 significa che trasformi un testo in numero) e copi in basso a quel punto potevi usare la tua formula con il SOMMA.PIÙ.SE(PREZZO_ORI;DATA_RESO;">="&$B$2;DATA_RESO;"<="&$B$3;COD_CAT;$A35) perchè lavora direttamente su degli intervalli e non su delle matrici
ciao Stefano
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#16
Ciao Canapone, ho risolto il problema delle faccine adesso quando farai ;) :) ;( come puoi notare non ti da più la faccina.
praticamente sono andato nelle impostazioni del forum ed ho assegnato ad ogni faccina dei caratteri diversi...
Ciao
 
Ultima modifica da un moderatore:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!