Quiz del Giorno #2 Rango e classifica

Stato
Discussione chiusa ad ulteriori risposte.
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#1
Ciao Oggi un bel grattacapo!
Come potete vedere nella colonna A2:A13 ho dei numeri ordinati dal più grande al più piccolo e nella colonna B2:B13 con la funzione =RANGO(A2;$A$2:$A$21) ho ottenuto un risultato che non mi soddisfa perché quando ci sono dei numeri duplicati mi salta il numero, invece io sono intenzionato ad ottenere un risultato come quello che ho scritto a mano nella colonna C2:C13
ciao

Row\Col

A​

B​

C​

1​

PUNTEGGIO

errato

Corretto

2​

200​

1​

1​

3​

200​

1​

1​

4​

160​

3​

2​

5​

150​

4​

3​

6​

150​

4​

3​

7​

125​

6​

4​

8​

125​

6​

4​

9​

125​

6​

4​

10​

100​

9​

5​

11​

100​

9​

5​

12​

99​

11​

6​

13​

99​

11​

6​

 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#2
Ciao Gerardo.

ho fatto una prova con questa formula.

=MATR.SOMMA.PRODOTTO((B2<B$2:B$13)/CONTA.SE(B$2:B$13;B$2:B$13))+1

Sembra funzioni
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#3
Ciao Canapone sei un Grande!!
e ti ringrazio di aver accettato di far parte dello Staff di Forumexcel.it

Io ho provato a fare una formula matrice con il FREQUENZA solo che bisogna fare CTRL+SHIFT+ENTER

in D2
=SOMMA(SE(A2<$A$2:$A$21;--(FREQUENZA($A$2:$A$20;$A$2:$A$20)>0)))+1

Ciao Canapone e grazie per la tua generosità

Row\Col

A​

B​

C​

D​

1​

PUNTEGGIO

errato

Corretto

Classifica

2​

200​

1​

1​

1​

3​

200​

1​

1​

1​

4​

160​

3​

2​

2​

5​

150​

4​

3​

3​

6​

150​

4​

3​

3​

7​

125​

6​

4​

4​

8​

125​

6​

4​

4​

9​

125​

6​

4​

4​

10​

100​

9​

5​

5​

11​

100​

9​

5​

5​

12​

99​

11​

6​

6​

13​

99​

11​

6​

6​

14​

78​

13​

7​

7​

15​

78​

13​

7​

7​

16​

55​

15​

8​

8​

17​

52​

16​

9​

9​

18​

42​

17​

10​

10​

19​

42​

17​

10​

10​

20​

42​

17​

10​

10​

21​

42​

17​

10​

10​


 

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#4
Ciao,

stessa formula di Gerardo

=MATR.SOMMA.PRODOTTO((A2<$A$2:$A$21)*(FREQUENZA($A$2:$A$20;$A$2:$A$20)>0))+1

non ha bisogno dello stato matriciale.

Saluti
 
Stato
Discussione chiusa ad ulteriori risposte.

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!