Risolto Raggruppare celle piene sparse nella stessa colonna

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
13,330
175
63
Como
2011MAC 2016WIN
Miglior risposte
88
#1
  • ges

    ges

Salve a tutti e un saluto a Gerardo Zuccalà che seguo da tempo su you tube da tempo al quale rinnovo i ringraziamenti per questo forum.

Ho il seguente problema che non riesco a risolvere.

Ho una lista di circa mille prodotti, che ho bisogno di tenere rigorosamente in un certo ordine, ogni prodotto è associato a dei nominativi che mi devono inviare dei dati, pertanto ho aggiunto alle celle adiacenti a ciascun prodotto la formula =SE(C2<>"";"";"B2") (in D2, D3, ecc. inserisco il dato che mi inviano, in E2, E3, c'è il nome corrispondente a quel dato, che "sparisce" quando il dato viene inserito).

A questo punto mi trovo con una cinquantina di dati mancanti e quindi altrettanti nomi sparsi nella lunga lista di excel, vorrei trovare un modo con le formule (non usando macro) di avere i nomi mancati uno dietro l'altro eliminando quindi le celle che risultano vuote.

Allego un'immagine come esempio (in D2,D3,D4,D5 c'è la formula sopra riportata)
 
Ultima modifica da un moderatore:

Canapone

Excel Expert
Moderatore
Expert
2 Giugno 2015
1,487
162
63
Firenze
2010 su Win
Miglior risposte
73
#3
Ciao a tutti,

un possibile approccio


=SE.ERRORE(INDICE($B$2:$B$1000;AGGREGA(15;6;RIF.RIGA($A$2:$A$1000)-1/($C$2:$C$1000="");RIF.RIGA(A1)));"")&""

La colonna D (dati mancanti) non viene letta dalla formula.

Saluti
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#4
Ciao Ges
Grazie per la domanda
un consiglio.. quando inserisci un griglia o tabella come questa , ti consiglio (se puoi se vuoi) di non inserire immagini in formato .gif .png .jpg perchè non sono direttamente trascrivibile in excel e di conseguenza si perde tempo a copiare tutto i dataset, indi per cui ti consiglio di usare il
il bbcode per griglie e bordi che è direttamante copiabile in excel, se non sai come fare clicca qui nella mia firma e ti farò vedere. ciao
 
30 Maggio 2015
5,319
72
48
50
Milano, Italy
office 365/2016
Miglior risposte
21
#5
Ciao canapone ho preso spunto dalla tua formula per fare una variante per coloro che hanno la versione di excel 2007 e precedenti che non hanno la funzione AGGREGA
per far funzionare queste formule bisogna attivarle con i tasti CTRL+SHIFT+ENTER


in F2:
=SE.ERRORE(INDICE($B$2:$B$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")


in G2:
=SE.ERRORE(INDICE($A$2:$A$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")

in H2:
=SE.ERRORE(INDICE($C$2:$C$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")
 

ges

Excel/VBA Expert
Amministratore
Expert
21 Giugno 2015
13,330
175
63
Como
2011MAC 2016WIN
Miglior risposte
88
#6
  • ges

    ges

Ragazzi... che dire .. siete fantastici!!!!
Grazie per avermi risolto il problema.
Ges

P.S. - Gerardo, scusami per il file jpeg la prossima volta vedrò di usare il bbcode per griglie e bordi. Grazie
 

Esse Depi

Utente abituale
25 Maggio 2017
154
0
16
44
Ferrara
2013
Miglior risposte
0
#8
Buonasera a tutti,
mi collego a questo vecchio post per chiedere se c'è un file excel allegato, perchè non riesco a capire esattamente come utilizzare le formule proposte.
Grazie per l'attenzione
 

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
13,037
186
63
65
Napoli
2013
Miglior risposte
99
#9
Scusa Esse Depi @Esse Depi ma cosa c’entra la tua domanda con questa discussione vecchia e sepolta?

Apri una nuova discussione e risottoponi il problema.
 

Esse Depi

Utente abituale
25 Maggio 2017
154
0
16
44
Ferrara
2013
Miglior risposte
0
#10
cercando sul forum ho comunque trovato un aiuto in "come raggruppare numeri escludendo celle vuote dal basso verso l'alto"
grazie comunque del suggerimento nel caso aprirò una nuova discussione
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!