Domanda Raggruppare e sommare i valori delle righe che hanno gli stessi codici

luca89luca

Utente junior
15 Febbraio 2021
22
1
OPEN OFFICE
0
Raggruppare e sommare i valori delle righe che hanno gli stessi codici

Buonasera a tutti, avrei un quesito:

Data una lista di prodotti composta da: brand, codice prodotto e quantità avrei bisogno di raggruppare e sommare i valori delle righe che hanno gli stessi codici?!

Allego un excel di prova per farvi capire nella pratica cosa vorrei fare
 

Allegati

Alessandro

Utente assiduo
18 Settembre 2015
1.051
38
49
Roma
2010 64 bit
4
Ciao,
ha ragione Alfredo (cappello_saluta).
Provaci.
Prova così: ti metti in D34 e scrivi
=SOMMA.PIÙ.SE( e poi leggerai int_somma;intervallo_criteri1;criteri1....
in pratica è un aiuto che excel ti da.
e sono da leggere così
int_somma è l'intervallo che vuoi che sommi (quindi la col.C)
e poi punto e virgola
intervallo_criteri1 è l'intervallo dove vuoi controllare il criterio che andremo a scrivere ora, quindi la col. A
e poi punto e virgola
criteri1è il criterio quindi che sia uguale a A34
e poi punto e virgola
e fatto il primo criterio vai con il secondo perchè vuoi che i totali siano sia uguale alla col. A che col. B
e chiudi parentesi
Fai attenzione a quando trascini in giu.
a dopo.
ciao
ale
 

Alessandro

Utente assiduo
18 Settembre 2015
1.051
38
49
Roma
2010 64 bit
4
al volo ho questa
=SOMMA.PIÙ.SE($C$3:$C$29;$A$3:$A$29;A34;$B$3:$B$29;B34)
o questa
=MATR.SOMMA.PRODOTTO(($C$3:$C$29)*($B$3:$B$29=B34)*($A$3:$A$29=A34)) (forse questa funziona...boh)
ma non ti funziona con il 2003...
boh...
ciao
ale
 

Rubik72

Excel/VBA Expert
Supermoderatore
12 Dicembre 2015
11.697
845
49
Cosenza
Excel 2016
984
Un saluto a tutti.
Prova con:

A34=SE.ERRORE(INDICE(A$3:A$29;PICCOLO(SE(FREQUENZA(CONFRONTA($A$3:$A$29&$B$3:$B$29;$A$3:$A$29&$B$3:$B$29;0);CONFRONTA($A$3:$A$29&$B$3:$B$29;$A$3:$A$29&$B$3:$B$29;0))>0;RIF.RIGA($A$3:$A$29)-RIF.RIGA($A$3)+1);RIGHE($A$1:A1)));"")
in formato matriciale (confermare con CTRL+SHIFT+ENTER) da ricopiare in basso e a destra

C34=MATR.SOMMA.PRODOTTO(($C$3:$C$29)*($A$3:$A$29=A34)*($B$3:$B$29=B34))
da ricopiare in basso

[EDIT]: visto che Excel 2003 NON ha la funzione MATR.SOMMA.PRODOTTO, usa:

C34=SOMMA(($C$3:$C$29)*($A$3:$A$29=A34)*($B$3:$B$29=B34))
sempre in formato matriciale (confermare con CTRL+SHIFT+ENTER)
 
Ultima modifica:
  • Like
Reactions: Terio

Rubik72

Excel/VBA Expert
Supermoderatore
12 Dicembre 2015
11.697
845
49
Cosenza
Excel 2016
984
Fai prima a fare un test direttamente sul nuovo PC.

Se hai risolto, segna la discussione come risolta (se non sai come fare leggi gli Avvisi dello Staff) assegnando la "coppa" alla miglior risposta.
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!