Risolto Ricerca e conteggio di nomi.

Carlo58

Utente junior
18 Maggio 2018
69
8
Italia
2016 su Ww. 10
1
Non sono riuscito a trovare una formula che, come da condizioni descritte nell'alegato, riesca a verificare e contare, l'eventuale presenza di un qualsiasi nome all'interno di una colonna.

Ritenete sia fattibile anche senza usare le macro?
Graz
ie.
 

Allegati

Bruno

Utente abituale
Expert
13 Settembre 2015
599
43
Italy
365/64 Bit W10
45
Ciao

Avviso: non si devono mai utilizzare le celle unite per poi effettuare ricerche sia con formule che con codice vba.

Ecco una possibile formula da inserire nel foglio senza modificare lo schema.
In L9 la formula matriciale da confermare con Ctrl Alt Invio

=SOMMA(SE(C4:C21=$I$9;SE(E5:E22>0;SE(($H$2-$L$6)<=C5:C22;1;0);0);0))

Lascio a te le verifiche dei criteri che hai richiesto
 

genio66

Utente assiduo
Expert
25 Marzo 2017
1.000
63
Friuli
LibreOffice 6
80
Ciao potresti provare anche con
=MATR.SOMMA.PRODOTTO((C4:C20=I9)*(E5:E21<>"")*(E5:E21>(E5:E21-L6)))
 

Carlo58

Utente junior
18 Maggio 2018
69
8
Italia
2016 su Ww. 10
1
Buongiorno e grazie a bruno e genio66 per il vostro interessamento.
Le sto provando sul pc e incollando le formule su L9 riscontro questi risultati:

La formula di Bruno mi restituisce il totale di 0.

La formula di genio66, funziona bene ma parzialmente.
O meglio, fa quanto richiesto ma non recepisce la limitazione del periodo di ricerca a ritroso, rispetto a oggi(), impostato in L6.
Ad esempio, se in C4 inserisco il nome di Paperinik, pur essendo gollegato al campo data dell'8 gennaio 2019, quindi ben oltre i 90 giorni da oggi, L6 lo totalizza come confacente all'impostazione di ricerca.
 

Bruno

Utente abituale
Expert
13 Settembre 2015
599
43
Italy
365/64 Bit W10
45
Ciao Carlo58

Certo che ottieni Zero, come già specificato...

In L9 la formula è matriciale da confermare con Ctrl Alt Invio
 

Carlo58

Utente junior
18 Maggio 2018
69
8
Italia
2016 su Ww. 10
1
Un'ulteriore precisazione:
rileggendo la richiesta originale che ho fatto, solo ora noto che l'ulteriore importante ricerca limitata a periodi retroattivi, l'ho descritta solo nell'esempio e non anche nelle condizioni richieste.
 

Carlo58

Utente junior
18 Maggio 2018
69
8
Italia
2016 su Ww. 10
1
Abbi pazienza Bruno ma esattamente cosa intendi per "confermare con Ctrl Alt Invio?
Ho fatto il copia -incolla della formula in L9, poi contemporaneamente gli ho cliccato Ctrtl Alt Invio, ma non cambia nulla. Dove sbaglio?
 

Bruno

Utente abituale
Expert
13 Settembre 2015
599
43
Italy
365/64 Bit W10
45
Ciao

In L9 la formula è matriciale da confermare con Ctrl Alt Invio
Guarda questo video...

 

genio66

Utente assiduo
Expert
25 Marzo 2017
1.000
63
Friuli
LibreOffice 6
80
Ciao Carlo58 @Carlo58 non so se hai risolto con la formula di Bruno @Bruno , comunque prova a modificare la mia formula così
=MATR.SOMMA.PRODOTTO((C4:C20=I9)*(E5:E21<>"")*(E5:E21>(H2-L6)))
Ps.: un saluto a tutti Saluto_saluto
 

Carlo58

Utente junior
18 Maggio 2018
69
8
Italia
2016 su Ww. 10
1
Vi ringrazio per l'utile supporto e il tempo dedicatomi.
Ho verificato e ancora una volta avete risolto questa mia richiesta!


:applausi: a tutti!
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!