Risolto righe alternate con formattazione

frank_ciccio

Utente abituale
4 Luglio 2019
789
20
onara - padova
2007 - 365
15
Ciao a tutti.
Nel file alleato in A6 riferito a =$A$6:$Q$180 c'è questa formattazione condizionale
Visual Basic:
=E($A6 <> "";  RESTO(RIF.RIGA();  2) = 1)
nella colonna A c'è una formula che si visualizza se in B c'è una data.
Finchè non c'è una data in B A non diventa gialla o resta bianca.
E' possibile con la formattazione che si visualizzi alternato fino alla fine del range
in cui ci sono le formule in colonna A cella A100 anche senza la data in colonna B?
Spero di essermi spiegato.
fc
 

Allegati

Bruno

Excel/VBA Expert
Staff
13 Settembre 2015
1.960
145
Italy
365/64 Bit W10
259
Ciao

In formattazione condizionale cella A6:
=SE(VAL.FORMULA($A6);RESTO(RIF.RIGA();2))
 

Bruno

Excel/VBA Expert
Staff
13 Settembre 2015
1.960
145
Italy
365/64 Bit W10
259
Ciao

=SE(VAL.FORMULA($A6)=VERO;RESTO(RIF.RIGA();2))

Sul primo file che stavo testando funzionava senza =VERO
 

rollis13

VBA Expert
Expert
15 Novembre 2015
2.067
95
Cordenons
Office 2016 x32
151
Un saluto a tutti Saluto_saluto .
F @frank_ciccio Qualcosa nel tuo file deve essere andato storto. Torna nella Formattazione Condizionale, simula una Modifica alla condizione e riconferma, magicamente la formattazione ora si è propagata a tutte le righe interessate.
 
  • Like
Reactions: Bruno

Anthony

Excel/VBA Expert
Expert
8 Settembre 2016
865
30
Ivrea (TO)
2003-2010-2016
27
Val.Formula e' stato introdotto con XL2013, non esiste su XL2007.
Se ti sta bene formattare solo fino a dove col A contiene dei dati allora usa =SE(A6<>"";RESTO(RIF.RIGA();2);0) altrimenti bisogna usare la antica GET.CELL o direttamente il vba, ma inevitabilmente potresti avere problemi di performance.

Aggiungo che se formatti il tuo intervallo come "Tabella" allora la colorazione sara' automatica su tutta la tabella

Ciao
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.060
345
Latina
Excel 2010
760
Un saluto a tutti
proviamo questa
inserisci in un modulo:
Visual Basic:
Function ISFORMULA(cel As Range) As Boolean
ISFORMULA = cel.HasFormula
End Function
poi in formattazione condizionata
usa:

=E(ISFORMULA($A6)=VERO;RESTO(RIF.RIGA();2)=0)
 

Allegati

Anthony

Excel/VBA Expert
Expert
8 Settembre 2016
865
30
Ivrea (TO)
2003-2010-2016
27
Vedi la proposta di Berna, sopra.

Volendo provare con Get.Cell=Info.Cella
1)Seleziona A6
2)Crea un intervallo nominato, assegnagli il nome FormulaA
3)Come "Riferito a" scrivi =INFO.CELLA(48;Foglio1!$A6)
Poi come formula per la formattazione condizionale del tuo intervallo userai la formula =SE(FormulaA;RESTO(RIF.RIGA();2);0)

Ciao
 

Anthony

Excel/VBA Expert
Expert
8 Settembre 2016
865
30
Ivrea (TO)
2003-2010-2016
27
Se vuoi creare una formattazione alternata allora la seconda formula sara':
Visual Basic:
=SE(FormulaA;RESTO(1+RIF.RIGA();2);0)
PERO' secondo me e' molto piu' semplice che formatti l'intervallo delle formule come "Tabella"; la formattazione e' automatica, le formule si "propagano" su tutta la colonna, la tabella si allunga da sola quando arrivi all'ultima cella (se usi il Tab per avanzare tra le celle) o manualmente usando "il manico" presente sull'ultima cella.
Vedi l'esempio su Foglio2 di questo file (il tuo adattato): https://www.dropbox.com/s/e5iaiu70n... altern con formule - antony_c01018.xlsm?dl=0

(Nota che la formula in A6 l'ho cambiata visto che in A5 ho messo una intestazione di colonna)

Ciao
 
  • Like
Reactions: rollis13

frank_ciccio

Utente abituale
4 Luglio 2019
789
20
onara - padova
2007 - 365
15
:confusostelle:
Ho provato qualcosa qui a casa sia la soluzione di antony che berna.
Tutte e due sono per la formattazione condizionale.
Nel file che devo inserire le soluzioni di berna o antony purtroppo mi sono accorto che ci sono molte altre formattazioni.
Queste 2 di berna o antony diventano prioritarie e non riesco a spostarle per non escludere le altre.
E' possibile altra alternativa tipo colorare le righe senza usare le formattazioni?
 

frank_ciccio

Utente abituale
4 Luglio 2019
789
20
onara - padova
2007 - 365
15
Questo allegato è una parte del file con la soluzione di antony.
La formattazione gialla è prioritaria e non si visualizzano le altre che sono nelle righe.
Esempio se scrivo nelle colonne M/N/O/P una lettera questa cella diventa verde come la riga 7
Così anche per le colonne J/L se metto una data inferiore ad oggi diventano rosse.
Prioritarie devono diventare tutte le formattazioni che non sono delle formule in questo caso di antony.
fc
 

Allegati

frank_ciccio

Utente abituale
4 Luglio 2019
789
20
onara - padova
2007 - 365
15
In alternativa alla formattazione ho trovato questa macro che colora le righe:

Visual Basic:
Sub ColorAlternate()

Dim LR As Long, i As Long

'Stop the screen from flickering
Application.ScreenUpdating = False

'Find the last filled row in column A
LR = Range("A" & Rows.Count).End(xlUp).Row

'Loop through the filled rows in steps of 2
For i = 2 To LR Step 2

'Colour alternate rows
    Rows(i).EntireRow.Interior.ColorIndex = 6
Next i

'Turn screen updating on again
Application.ScreenUpdating = True

End Sub
è possibile modificarla perchè funzioni:
dalla riga 6 da colonna A fino a colonna Q
 

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
8.060
345
Latina
Excel 2010
760
Ciao
non ho capito bene cosa vorresti fare
ma, se vuoi che le altre formattazioni abbiano la prevalenza sulle righe alterne
dovresti provare a rifare il tutto...
seguendo questo ordine
mettere come prime regole quelle delle righe alterne
e poi re altre.... buon lavoro
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!