Risolto Rinominare i valori con il codice.

raphael

Utente abituale
11 Dicembre 2018
109
18
excel 2010
0
Buongiorno. Buon Anno 2021. 5 lunghe colonne contengono 5 valori per riga indicati sempre con le sole lettere A,B,C.
Ogni riga puo contenere solo 21 combinazioni possibili di queste tre lettere.
Esempio: A B B C A, oppure A A C C C.
Per facilità di lettura in vista di una manipolazione si richiede d’indicare le 21 combinazioni possibili con le lettere dell’alfabeto. Esempio: A B B C A con la lettera H, e A A C C C con la lettera L. Il file che accompagna la richiesta contiene sia le lunghe colonne, sia il codice alfabetico di come chiamarle.
Ringrazio e …Buon Anno 2021 senza Covid e brindiamo al Vaccino! Arrivederci
 

Allegati

Canapone

Excel Expert
Moderatore
2 Giugno 2015
2.519
145
Firenze
Excel 2016
349
Ciao a tutti,

in G1 da copiare in basso:

=CERCA.VERT(MATR.SOMMA.PRODOTTO(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI(A1:E1;"A";0);"B";1);"C";10)+0);{0\"A".1\"B".10\"C".2\"D".11\"E".20\"F".3\"G".12\"H".21\"I".30\"L".4\"M".13\"N".22\"O".31\"P".40\"Q".50\"R".5\"S".14\"T".23\"U".32\"V".41\"Z"};2;0)

o similmente

=CERCA(MATR.SOMMA.PRODOTTO(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI(A1:E1;"A";0);"B";1);"C";10)+0);{0\"A".1\"B".2\"D".3\"G".4\"M".5\"S".10\"C".11\"E".12\"H".13\"N".14\"T".20\"F".21\"I".22\"O".23\"U".30\"L".31\"P".32\"V".40\"Q".41\"Z".50\"R"})


Saluti
 
  • Like
Reactions: lukereds

raphael

Utente abituale
11 Dicembre 2018
109
18
excel 2010
0
ciao
non ho mica capito cosa vuoi fare:dubbioso:

anche perchè tu metti H
su
A B B C A

ma H nella lista è
A A B B C
Grazie Gianfranco di avere risposto.Certo perché non é importante la disposizione delle lettere.Possono essere mescolate.Infatti A B B C A che ho indicato con la lettera H non é presente nel registro accanto semplicemente perché é una delle forme con cui 2A ,2 B , 1C si ..esprime.Spero sia chiaro.
 

raphael

Utente abituale
11 Dicembre 2018
109
18
excel 2010
0
Grazie Canapone di avere trovato la risposta giusta! Tutto funziona perfettamente.Arrivederci e grazie. La Coppa e un Buon 2021 !!!
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!