Risolto scadenze

t.corvo

Utente abituale
1 Ottobre 2016
231
16
46
campobasso
2007,2010,2013
1
Signori buongiorno
spero che questi giorni per la maggior parte siano di riposo dovuto non forzato.
Porto alla vostra attenzione il file in allegato dove vengono riportati alcuni prodotti con la relativa scadenza che dovrebbero subire un taglio prezzo per giorni di mancanti alla scadenza tipo 3-5-7, e dovrebbero essere visibili nella casella solo se hanno quei gg di scadenza, per ultimo tutti i prezzi derivanti dovrebbero essere arrotondati a a 5 e 9 decimale finale.
non so se è fattibile perché mi sono dimenato sugli arrotondamenti senza alcun risultato , chiedo il vostro supporto per vedere se possibile realizzare al meglio questa tabella.
grazie dell'attenzione e buona giornata
 

Allegati

Hydraulics

Utente abituale
27 Luglio 2018
111
28
Udine
Office 365
14
Prova a vedere se una soluzione di questo tipo può andar bene.
Ho aggiunto nella riga 2 il numero di giorni mancanti alla scadenza nel caso fossero da modificare.

=SE($C6-OGGI()>=G$2;SE(ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05)<ARROTONDA.ECCESSO(ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05);0,1);ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05);ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05)-0,01);"")

Per verificare la correttezza della regola di arrotondamento basta inserire 0% in una qualsiasi colonna e confrontare con il prezzo pieno.
 

Allegati

  • Like
Reactions: t.corvo

t.corvo

Utente abituale
1 Ottobre 2016
231
16
46
campobasso
2007,2010,2013
1
Sera grazie dell'aiuto ma purtroppo non corrisponde il risultato ti ho rimesso il file d'esempio , altra cosa che chiedevo sempre se possibile è quella di riempire il campo con i dati quando realmente mancano solo quei giorni esempio se mancano 5 gg appare nel campo dei 5 gg se mancano 10 gg si riempie il campo dei 10gg.
 

Allegati

Hydraulics

Utente abituale
27 Luglio 2018
111
28
Udine
Office 365
14
Per le date ho invertito il test, va inserito <= e non >=

=SE($C6-OGGI()<=G$2;SE(ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05)<ARROTONDA.ECCESSO(ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05);0,1);ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05);ARROTONDA.ECCESSO($D6*(1+$C$5-G$5)+0,001;0,05)-0,01);"")

Per il prezzo ho lavorato direttamente sul ricarico, per cui un 10% di sconto equivale a un prezzo base moltiplicato per 1.2 (30% - 10% = 0.2). Se vuoi calcolare diversamente non è un problema.
 
Ultima modifica:
  • Like
Reactions: t.corvo

t.corvo

Utente abituale
1 Ottobre 2016
231
16
46
campobasso
2007,2010,2013
1
Allego il file corretto.
grazie ancora per l'attenzione che hai dedicato alla mia richiesta Hydraulics @Hydraulics , il file e quasi perfetto l'unica cosa che manca sempre se possibile è far apparire solo il risultato dell'ultima data non quello delle precedenti, esempio se per data appare quella dei 3 giorni la cella del 7 e del 5 dovrebbe essere vuota. Sempre se possibile e grazie ancora
 

Hydraulics

Utente abituale
27 Luglio 2018
111
28
Udine
Office 365
14
Ci sono diversi modi di risolvere il problema. Propongo una piccola modifica alla formula a patto di inserire un valore aggiuntivo nel foglio di lavoro a destra del 3 che individua l'ultima scadenza.

=SE(E($C6-OGGI()<=G$2;$C6-OGGI()>H$2);SE(ARROTONDA.ECCESSO($F6*(1-G$5)+0,001;0,05)<ARROTONDA.ECCESSO(ARROTONDA.ECCESSO($F6*(1-G$5)+0,001;0,05);0,1);ARROTONDA.ECCESSO($F6*(1-G$5)+0,001;0,05);ARROTONDA.ECCESSO($F6*(1-G$5)+0,001;0,05)-0,01);"")

Allego il nuovo file.
 

Allegati

  • Like
Reactions: t.corvo

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!