Risolto Selezione dati in base a un filtro per province

francepalazz

Utente abituale
3 Maggio 2018
111
18
Agrigento
Excel 2019
2
Ciao a tutti, Vi chiedevo un aiuto in merito alla estrapolazione del numero di ditte in una determinata provincia, a seguito di un filtro dati.
Mi spiego meglio:
in cella J6 "Provincia" tramite il filtro, scelgo la sigla della Provincia.
Nella cella D3 mi dovrebbe risultare il numero delle ditte presenti nella provincia selezionata. se Agrigento n. 29; se Caltanissetta n° 18 ecc ecc....
Nella cella E3 mi dovrebbe risultare la provincia selezionata nella cella J6.
Vi allego il file excel "2021_prova_albo"
Vi ringrazio anticipatamente del Vostro aiuto.
 

Allegati

dodo47

Utente assiduo
Expert
18 Ottobre 2020
1.304
115
excel 2016
188
ciao
in D3:
=SUBTOTALE(3;J7:J216)

in E3:
=INDICE(J:J;MIN(SE(SUBTOTALE(3;SCARTO(J7;RIF.RIGA(J7:J216)-RIF.RIGA(J7);0));RIF.RIGA(J7:J216))))
matriciale

saluti
 

francepalazz

Utente abituale
3 Maggio 2018
111
18
Agrigento
Excel 2019
2
Dodo, ma intanto non capisco come inserire la formula matriciale.
Poi volevo dirti, che se filtro PA, mi dovrà dare i dati di Palermo. Ma se non inserisco nessun filtro, non mi dovrà scrivere PA ma solamente i dati totali
 

Gianfranco55

Utente senior
5 Novembre 2015
12.136
1.445
66
Valdagno
excel 365
1.250
ciao
per la matriciale

conferma
ctrl maiuscolo invio
( clicca sulla barra della formula e invece di dare invio
clicca su ctrl maiuscolo invio)
vedi le parentesi grafe.

per il vuoto
potresti usare
=SE($D$3=CONTA.VALORI($J$7:$J$216);"";INDICE(J:J;MIN(SE(SUBTOTALE(3;SCARTO(J7;RIF.RIGA(J7:J216)-RIF.RIGA(J7);0));RIF.RIGA(J7:J216)))))

ma se come nel tuo caso filtri altre colonne la prima cella della colonna J te la darà sempre
 

francepalazz

Utente abituale
3 Maggio 2018
111
18
Agrigento
Excel 2019
2
Ciao, ho provato a inserire le formule da Voi descritte.
Ma se inserisco due filtri per AG e per CL, in D3 mi da i totali di entrambe le provincie 47, mentre in E3 mi da CL, parrebbe che il totale siano di 47 solo per CL.
Forse con il filtro, la problematica diventa più complessa in excel.
Avete qualche consiglio su qualche altra soluzione che potrei attuare?
Oppure il classico elenco con dati Ag, Cl, Ct; ecc ecc?
Vi allego il file con le formule da Voi segnalate.
 

Allegati

dodo47

Utente assiduo
Expert
18 Ottobre 2020
1.304
115
excel 2016
188
ciao
in unica cella non con le formule...se vuoi una macro ...magari una udf

saluti
 
Ultima modifica:

cromagno

Excel/VBA Expert
Supermoderatore
9 Agosto 2015
7.924
245
41
Sardegna
2019 (32 bit)
451
Ciao,
visto che hai la versione 2019, puoi usare la funzione TESTO.UNISCI
In cella E3:
=TESTO.UNISCI(" - ";VERO;SE(VAL.NUMERO(CONFRONTA(B225:B233;SE(SUBTOTALE(3;SCARTO(J7;RIF.RIGA(J7:J216)-7;0));$J$7:$J$216;"");0));B225:B233;""))

Naturalmente se non usi filtri, in cella E3 avrai le sigle di tutte le province.
 

Gianfranco55

Utente senior
5 Novembre 2015
12.136
1.445
66
Valdagno
excel 365
1.250
ciao
incasinata ma funziona

leva le celle unite
in B2 da tirare a destra
=SE.ERRORE(INDICE(SE.ERRORE(INDICE($J$1:$J$1000;RIF.RIGA($J$7:$J$1000)*SUBTOTALE(3;SCARTO($J$7:$J$1000;RIF.RIGA($J$7:$J$1000)-MIN(RIF.RIGA($J$7:$J$1000));0;1)));"");CONFRONTA(0;INDICE(CONTA.SE($A$2:B$2;SE.ERRORE(INDICE($J$1:$J$1000;RIF.RIGA($J$7:$J$1000)*SUBTOTALE(3;SCARTO($J$7:$J$1000;RIF.RIGA($J$7:$J$1000)-MIN(RIF.RIGA($J$7:$J$1000));0;1)));"")&""););0));"")

non riesco alla prima cella levare lo 0
lo si supera colorando di bianco il carattere della cella B2
 

francepalazz

Utente abituale
3 Maggio 2018
111
18
Agrigento
Excel 2019
2
Gianfranco, onestamente non ho capito niente cosa devo fare
Ho già inserito in cella D3 la formula =SUBTOTALE(3;J7:J216)
mentre in E3 la formula SE($D$3=CONTA.VALORI($J$7:$J$216);"";INDICE(J:J;MIN(SE(SUBTOTALE(3;SCARTO(J7;RIF.RIGA(J7:J216)-RIF.RIGA(J7);0));RIF.RIGA(J7:J216)))))
Sono quelle che mi avete indicato Voi.
Non sono un grande esperto, quindi se mi potete descrivere cosa devo fare.
Vi ringrazio a tutti per il vostro interessamento
 

Gianfranco55

Utente senior
5 Novembre 2015
12.136
1.445
66
Valdagno
excel 365
1.250
ciao
se vuoi le sigle tutte su una cella usi quella di Cromagno
se le vuoi una per cella la mia e la tiri a destra.
chiaro che le celle unite non ci devono essere.
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!