Risolto Verifica contenuto di una cella

taranto57

Utente junior
20 Giugno 2018
63
6
Taranto
Excel 2013
2
buonasera,
vorrei un aiuto per risolvere il seguente problema:
da A2 a An (formato testo) scrivo dei dati di qualsiasi lunghezza separati da un segno (nel mio caso -, ma potrebbe essere un'altro qualsiasi , ; ecc.) da B2 a Bn (formato testo) riporto uno dei valori che potrebbero essere contenuti tra i segni di delimitazione. Da C2 a Cn vorrei avere il risultato (si/no) che indichi la presenza o meno del testo da trovare. Allego file esempio.
Ringrazio in anticipo.
Michele
 

Allegati

paoloard

Utente assiduo
Expert
18 Febbraio 2018
1.349
83
prov. BO
2016
157
A chi la fa più corta?
=SE.ERRORE(SE(TROVA(B2;A2);"si");"no")

alfrimpa @alfrimpa : se non sbaglio la tua dovrebbe errore se non trova.
 

taranto57

Utente junior
20 Giugno 2018
63
6
Taranto
Excel 2013
2
Una criticità, se nella stinga pricipale indico 101-107 la ricerca del 10 mi da esito positivo. In questo caso dovrebbe essene "no" in quanto il valore ricercato è diverso da 101 e 107
 

taranto57

Utente junior
20 Giugno 2018
63
6
Taranto
Excel 2013
2
=SE(CONTA.SE(A2;"*"&B2&"*");"si";"no") risponde appieno alla mia esigenza. Riesce a distinguere correttamente il valore da cercare, grazie nuovamente
 

taranto57

Utente junior
20 Giugno 2018
63
6
Taranto
Excel 2013
2
=SE.ERRORE(SE(TROVA("-"&B2&"-";A2);"si");"no") , con questa ho risolto la criticità evidenziata da Paoloard. (quante cose devo imparare!!!)
 

alfrimpa

VBA Expert
Supermoderatore
Expert
18 Dicembre 2015
20.682
1.713
66
Napoli
2013
398
Anche se risolta mi piace proporre una piccola Function in VBA (da inserire in un modulo standard) che fa lo stesso lavoro.

Visual Basic:
Function TrovaIn(testo As Range, elemento As Range)
If InStr(1, testo.Value, elemento.Value) <> 0 Then
    TrovaIn = "si"
    Else
    TrovaIn = "no"
End If
End Function
E sul foglio in C2 scrivere

=TrovaIn(A2;B2)

e ricopiare in basso
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!